Reports of multiple report emails being sent
Incident Report for HappyCo
Resolved
This incident has been resolved.
Posted over 3 years ago. Apr 26, 2016 - 18:13 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted over 3 years ago. Apr 25, 2016 - 20:08 UTC
Investigating
We are currently investigating this issue.
Posted over 3 years ago. Apr 25, 2016 - 17:55 UTC