Potential service disruption
Incident Report for HappyCo
Resolved
The service disruption on the HappyCo platform has been resolved.
Posted Oct 22, 2020 - 22:46 UTC
Investigating
We've seen a potential disruption in the HappyCo platform. We're investigating it!
Posted Oct 22, 2020 - 22:46 UTC
This incident affected: Management Portal and Report Access, Mobile Sync, Happy Insights, Integrations, and Email Service.