Scheduled downtime
Incident Report for HappyCo
Resolved
This incident has been resolved.
Posted Apr 28, 2024 - 09:11 UTC
Monitoring
Maintenance has been completed and we are monitoring performance
Posted Apr 28, 2024 - 07:20 UTC
Investigating
We are progressing with scheduled downtime for server maintenance. HappyCo services are temporarily unavailable.
Posted Apr 28, 2024 - 06:41 UTC
This incident affected: Management Portal and Report Access, Mobile Sync, and Integrations.