Reduced Performance on Happy Manage
Incident Report for HappyCo
Resolved
This incident has been resolved.
Posted almost 2 years ago. Jan 09, 2018 - 20:59 UTC
Monitoring
An update to our backend has been released. Engineering are continuing to monitor performance of all systems.
Posted almost 2 years ago. Jan 09, 2018 - 01:11 UTC
Identified
Engineering have identified performance issues with some parts of Happy Manage and are working on a fix. Customers may experience delays on page loads and potentially some timeouts. If affected, continue trying, or return later, if possible. Please monitor this page for updates.
Posted almost 2 years ago. Jan 05, 2018 - 01:14 UTC