Degraded Performance
Incident Report for HappyCo
Resolved
Engineering confirm issue now resolved
Posted over 1 year ago. Jan 29, 2018 - 07:26 UTC
Monitoring
Performance has been restored and engineering are monitoring the situation
Posted over 1 year ago. Jan 29, 2018 - 06:33 UTC
Investigating
Engineering team are investigating an incident with parts of our service.
Posted over 1 year ago. Jan 29, 2018 - 06:26 UTC