Scheduled outage - planned maintenance
Incident Report for HappyCo
Resolved
Maintenance has been completed. All services are restored
Posted May 02, 2021 - 07:26 UTC
Update
We are continuing to investigate this issue.
Posted May 02, 2021 - 07:11 UTC
Investigating
HappyCo services are currently down to allow for planned maintenance to be completed. Services will be restored shortly.
Posted May 02, 2021 - 07:10 UTC
This incident affected: HappyCo Website, Management Portal and Report Access, Mobile Sync, Happy Insights, and Integrations.