Intermittent issues with report generation

Incident Report for HappyCo

Resolved

We've monitored throughout June 3, 2026 and are seeing successful report generation with over 97% completing in under 60s, with more than 99.5% completing under one hour.
Posted Jun 03, 2026 - 22:01 UTC

Monitoring

We have introduced a series of performance improvements and are seeing report time generation consistently under 1min for the majority of reports. We will continue to monitor throughout the day.
Posted Jun 03, 2026 - 14:41 UTC

Update

We have confirmed reports are generating successfully but a subset are delayed. Our engineering team is working to address these slowdowns.
Posted Jun 03, 2026 - 10:47 UTC

Update

Our engineering team is continuing to work on a fix.
Posted Jun 03, 2026 - 07:07 UTC

Identified

The issue has been identified and our team is working on a fix.
Posted Jun 03, 2026 - 02:56 UTC

Update

We're continuing our investigation
Posted Jun 03, 2026 - 00:59 UTC

Update

We're continuing to investigate
Posted Jun 03, 2026 - 00:18 UTC

Investigating

Some customers are experiencing intermittent issues with generating inspection reports. Our team is investigating.
Posted Jun 02, 2026 - 23:33 UTC
This incident affected: Management Portal and Report Access.