Success rates are returning to normal across all services.
Posted Apr 08, 2026 - 06:12 UTC
Monitoring
We’ve implemented changes and are seeing improvements in success rates for affected actions.
Posted Apr 07, 2026 - 22:44 UTC
Investigating
On 31 March 2026, between approximately 5:00 PM and midnight UTC (1:00 PM – 8:00 PM EST), customers experienced degraded performance across Happy Property. We are aware of the impact this caused and are actively investigating. Ongoing intermittent issues have been reported in:
- Report downloads failing or not completing - Errors when completing inspections - General slowness and intermittent failures across the platform
Our engineering team is investigating the root cause. We will provide updates as our investigation progresses.
Posted Apr 07, 2026 - 04:37 UTC
This incident affected: Management Portal and Report Access.