Task Jobs down

Incident Report for HappyCo

Resolved

This incident has been resolved.
Posted Aug 04, 2025 - 23:01 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 04, 2025 - 22:28 UTC

Update

The problem has been identified. We’re remediating and are monitoring.
Posted Aug 04, 2025 - 19:42 UTC

Update

We’re seeing reduced performance for Tasks assignments right now. Engineering has improved performance and is now investigating the root cause.
Posted Aug 04, 2025 - 19:01 UTC

Investigating

Task assignment notifications might be delayed. We are currently investigating this issue.
Posted Aug 04, 2025 - 17:31 UTC
This incident affected: Management Portal and Report Access and Mobile Sync.