Report downloading issues
Incident Report for HappyCo
Resolved
This incident has been resolved.
Posted Oct 01, 2021 - 09:01 UTC
Identified
We are aware of an issue preventing users from downloading newly created reports. We have determined the cause of the issue and are working on a resolution.

Please note that pre-existing reports are unaffected.
Posted Oct 01, 2021 - 05:02 UTC
This incident affected: Management Portal and Report Access.