An updated version of the Happy Property Maintenance App has been released to iOS and Android stores. Update your App to resolve any remaining issues.
Posted Jun 25, 2025 - 11:46 UTC
Update
We have further narrowed down the issue to only occurring if you have multiple properties selected in the app when attempting to create a work order or inspection.
By using the single property selector before attempting to create a work order or inspection, you will be able to avoid the issue.
The underlying issue has been identified and a fix is being implemented in an updated version of the Happy Property Maintenance App.
We will provide an update when the new version of the App is available for download.
Posted Jun 25, 2025 - 01:33 UTC
Update
Our technical team has confirmed that the location list will work if you select only one property. We are implementing a fix for the underlying issue for multiple property selection.
Posted Jun 25, 2025 - 00:12 UTC
Identified
The issue has been identified and a fix is being implemented.