Call Complete Web Interface Unavailable
Incident Report for HappyCo
Resolved
This incident has been resolved. Thank you for your patience.
Posted Feb 12, 2024 - 19:33 UTC
Monitoring
A fix has been implemented, and we are monitoring the results.
Posted Feb 12, 2024 - 17:36 UTC
Identified
We have identified the issue and are investigating.
Posted Feb 12, 2024 - 16:40 UTC
Investigating
Customers are unable to access features of Call Complete via the web.

We are actively investigating this issue.
Posted Feb 12, 2024 - 14:55 UTC
This incident affected: Management Portal and Report Access.