Widespread Errors

Incident Report for HappyCo

Resolved

During our monitoring period of 2.5 hours, all systems have continued to perform as expected.

All systems are fully operational.
Posted Jul 21, 2025 - 20:50 UTC

Update

We are continuing to monitor systems but all indicators show systems have fully recovered.

We have increased job processing for PMS syncs to work through the backlong; job queues have returned to expected levels.
Posted Jul 21, 2025 - 18:14 UTC

Monitoring

We have implemented some adjustments to address a performance issue. Currently all systems showing healthy operation. We are actively monitoring the situation.
Posted Jul 21, 2025 - 17:29 UTC

Investigating

We are currently investigating reports of widespread errors across the platform.
Posted Jul 21, 2025 - 16:12 UTC
This incident affected: HappyCo Website, Management Portal and Report Access, Mobile Sync, Happy Insights, Integrations, and Email Service.