Call Management Partial Service Degradation

Incident Report for HappyCo

Resolved

Call Management continues to operate normally.
Posted Jan 25, 2026 - 19:59 UTC

Monitoring

We have introduced a fix to Call Management which has addressed slow application performance.

We are continuing to monitor application performance.
Posted Jan 25, 2026 - 19:05 UTC

Investigating

We are seeing slow application performance within the Call Management Product and are investigating.

IVR functionality is NOT impacted.
Posted Jan 25, 2026 - 18:31 UTC