Errors with incoming calls reporting busy in Call Complete.

Incident Report for HappyCo

Resolved

This incident has been resolved.
Posted May 08, 2026 - 22:47 UTC

Monitoring

Services are restored and we are monitoring.
Posted May 08, 2026 - 22:18 UTC

Identified

The issue has been identified and a fix is being deployed.
Posted May 08, 2026 - 21:47 UTC

Investigating

We are experiencing intermittent failures with our IVR infrastructure resulting in user busy signals in Call Complete.
Posted May 08, 2026 - 21:32 UTC
This incident affected: HappyCo Website.