Call Management provisioning experiencing processing delays

Incident Report for HappyCo

Resolved

A fix has been implemented and Call Management provisioning is operating as normal.
Posted Nov 19, 2025 - 05:03 UTC

Identified

We've identified the issue and working to implement a fix.
Posted Nov 19, 2025 - 03:02 UTC

Update

We are continuing to investigate the cause of Call Management provisioning delays.
Posted Nov 19, 2025 - 02:12 UTC

Investigating

Newly provisioned Call Management services are not visible in the Management Portal. We are investigating the cause.
Posted Nov 19, 2025 - 01:14 UTC
This incident affected: Management Portal and Report Access.