Users unable to access management portal

Incident Report for HappyCo

Resolved

This has been resolved.
Posted Apr 08, 2026 - 21:03 UTC

Monitoring

A fix has been implemented and we're monitoring.
Posted Apr 08, 2026 - 19:32 UTC

Investigating

We are currently investigating users being unable to login.
Posted Apr 08, 2026 - 19:24 UTC
This incident affected: Management Portal and Report Access.