Potential service disruption - Reporting

Incident Report for HappyCo

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 00:40 UTC

Monitoring

GCP is reporting restoration of most services. Errors and issues in HappyCo appear resolved. We will continue to monitor.
Posted Jun 12, 2025 - 22:22 UTC

Update

Service Alert: Ongoing Google Cloud Outage Impacting HappyCo

Incident Overview
We’re currently tracking a major outage affecting Google Cloud services, which began on June 12, 2025. Since certain HappyCo features depend on Google Cloud infrastructure, some users may be experiencing problems such as issues with Task Attachments.

Current Situation
According to Google, this is a global issue tied to Google’s Identity and Access Management systems. As a result, multiple services—HappyCo included—are facing widespread performance interruptions. Businesses worldwide are being impacted by this service degradation.

How to Stay Informed
To track developments, you can refer to the following resources:

HappyCo Status Page: https://status.happyco.com/
Google Cloud Status Dashboard: https://status.cloud.google.com/
Posted Jun 12, 2025 - 19:46 UTC

Identified

An upstream outage in our cloud services provider is causing an interruption in reporting and report generation. We are monitoring.
Posted Jun 12, 2025 - 19:04 UTC
This incident affected: Happy Insights.