Degraded Application Performance

Incident Report for HappyCo

Resolved

This incident has been resolved.
Posted Mar 27, 2026 - 19:07 UTC

Monitoring

We've identified a fix and are actively monitoring to confirm full resolution.
Posted Mar 27, 2026 - 18:53 UTC

Investigating

We are currently investigating reports of degraded application performance.
Posted Mar 27, 2026 - 18:25 UTC
This incident affected: Management Portal and Report Access, Mobile Sync, and Integrations.