Our operators continue to confirm successful resolution; marking incident resolved.
Posted Oct 20, 2025 - 13:21 UTC
Update
All functionality is confirmed restored. We are continuing to monitor.
Posted Oct 20, 2025 - 11:58 UTC
Monitoring
Incoming calling has been fully restored. We are monitoring systems for any further anomalies.
Posted Oct 20, 2025 - 11:18 UTC
Update
Incoming calling has been partially restored. Residents can report Emergency calls via Call Complete and leave a message for our contact center. Our contact center will return the call to the resident to process the Emergency report.
Posted Oct 20, 2025 - 11:00 UTC
Investigating
Residents can report emergency issues as a regular issues via their Resident Portal for their community. Our operators are monitoring reported issues and will escalate them immediately.