Slower-than-expected Report Generation

Incident Report for HappyCo

Resolved

This incident has been resolved.
Posted Jun 04, 2026 - 20:32 UTC

Monitoring

We've identified and implemented a fix to resolve slow report generation and will continue monitoring
Posted Jun 04, 2026 - 17:46 UTC

Investigating

We're currently seeing slower-than-expected report generation and are investigating the issue.
Posted Jun 04, 2026 - 16:23 UTC
This incident affected: Management Portal and Report Access.