Increased error rates in Call Management

Incident Report for HappyCo

Resolved

This incident has been resolved.
Posted Jul 03, 2026 - 06:43 UTC

Update

We are continuing to investigate the issue - Calls and IVRs appear to be unaffected.
Posted Jul 03, 2026 - 06:17 UTC

Investigating

We are investigating reports of increased error rates in our Call Management product.
Posted Jul 03, 2026 - 05:24 UTC
This incident affected: Management Portal and Report Access.