Intermittent Failures

Incident Report for HappyCo

Resolved

This incident has been resolved.
Posted Apr 15, 2025 - 20:32 UTC

Monitoring

All services are operational. We are investigating potential DNS issues.
Posted Apr 15, 2025 - 20:01 UTC

Investigating

We are currently investigating reports of intermittent errors and failed page loading.
Posted Apr 15, 2025 - 18:59 UTC
This incident affected: Management Portal and Report Access, Happy Insights, Integrations, and Email Service.