Intermittent slow page loads

Incident Report for HappyCo

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 22:52 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 27, 2026 - 19:37 UTC

Update

We are continuing to investigate this issue.
Posted Feb 27, 2026 - 18:48 UTC

Investigating

We are currently experiencing intermittent slow page loads and are investigating.
Posted Feb 27, 2026 - 17:52 UTC
This incident affected: Management Portal and Report Access.