Task Creation Category Dropdown Misplaced
Incident Report for HappyCo
Postmortem

Summary

A software change was deployed that introduced a bug impacting task creation.

Impacted Systems

Task creation via the Web UI was unusable due to a positioning bug that pushed category selection outside of the browser viewport.

Resolution

A patch was deployed effectively reversing the offending change, restoring functionality.

Timeline of Events

1600 UTC: Issue reported

1841 UTC: Fix developed and tested

1916 UTC: Fix deployed and confirmed in staging

2010 UTC: Hotfix deployed to production resolving issue

Posted Aug 14, 2024 - 22:25 UTC

Resolved
This incident has been resolved.
Posted Aug 13, 2024 - 20:26 UTC
Monitoring
We've released a fix that addresses the mis-positioned category dropdown within Tasks.
Posted Aug 13, 2024 - 20:24 UTC
Update
We've identified the changes in question, related to an upgrade of two external dependencies, which caused the rendering placement bug.

We are in the process of releasing a hot-fix rolling back the version, which we've confirmed addresses the issue, with a resolution ETA of 3:15pm ET / 12:15pm PT.
Posted Aug 13, 2024 - 18:37 UTC
Identified
We're reviewing recent code changes to identify the root cause of the issue.
Posted Aug 13, 2024 - 18:04 UTC
Investigating
We have received reports of the category select dropdown displaying in the lower left-hand side of the screen, resulting in UX issues creating new tasks.
Posted Aug 13, 2024 - 16:44 UTC
This incident affected: Management Portal and Report Access.