Production Issues with Property

Incident Report for HappyCo

Resolved

This incident has been resolved.
Posted Mar 03, 2025 - 20:07 UTC

Update

We are continuing to monitor for any further issues.
Posted Mar 03, 2025 - 18:10 UTC

Monitoring

Services are restoring and we are monitoring.
Posted Mar 03, 2025 - 17:37 UTC

Investigating

We are currently investigating an issue impacting Property related features (e.g. Property Selector).
Posted Mar 03, 2025 - 16:55 UTC
This incident affected: Management Portal and Report Access.