All scheduled maintenance has been completed successfully. All services are fully restored and operating normally. Thank you for your patience.
Posted Dec 07, 2025 - 07:54 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 07, 2025 - 07:00 UTC
Scheduled
HappyCo will perform scheduled database maintenance on Sunday, December 7, between 2:00 AM and 5:00 AM EST. Some services may be unavailable for up to 2 hours during this window, further updates will be provided here.