Investigating intermittent degraded performance

Incident Report for HappyCo

Resolved

Systems are restored and healthy. We are continuing to monitor.
Posted Mar 04, 2025 - 21:15 UTC

Update

We are continuing to monitor for any further issues.
Posted Mar 04, 2025 - 21:09 UTC

Update

Applications and services are restored and being monitored. Task-related emails are suspended. We are working to quickly restore service.
Posted Mar 04, 2025 - 19:12 UTC

Update

We are working on restoring interrupted services.
Posted Mar 04, 2025 - 18:33 UTC

Monitoring

Services are recovering and we are continuing to monitor system health.
Posted Mar 04, 2025 - 17:31 UTC

Update

We are continuing to investigate this issue.
Posted Mar 04, 2025 - 16:31 UTC

Investigating

We are investigating possible performance degradation in some services.
Posted Mar 04, 2025 - 16:19 UTC
This incident affected: Management Portal and Report Access and Email Service.