Due Diligence Service Requests are Delayed

Incident Report for HappyCo

Resolved

This incident has been resolved.
Posted Apr 12, 2025 - 01:29 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 11, 2025 - 22:38 UTC

Update

Standard requests should be sent to dd@happy.co and include the DD Order name during this delay.

Once the connection is restored, all delayed Due Diligence Service Requests will be re-synced with our ticketing system.
Posted Apr 10, 2025 - 22:46 UTC

Investigating

Due Diligence Service Requests are not moving into HappyCo’s ticket queue. This may delay our response to customer Due Diligence requests.

Once the connection is restored, all delayed Due Diligence Service Requests will be re-synced with our ticketing system.
Posted Apr 10, 2025 - 22:39 UTC
This incident affected: Management Portal and Report Access.