Maintenance has been completed, and we are monitoring the results.
Posted Jun 16, 2024 - 06:11 UTC
Identified
We are conducting maintenance. Some services may be affected, including: * Happy Force ticket triaging (After Hours calls not affected) * Asset Management * Property Provisioning
Posted Jun 16, 2024 - 06:01 UTC
This incident affected: Management Portal and Report Access.