Degraded Application Performance

Incident Report for HappyCo

Resolved

This incident has been resolved.
Posted Mar 24, 2026 - 21:47 UTC

Monitoring

We have introduced a series of fixes that look to have resolved performance issues and will continue monitoring.
Posted Mar 24, 2026 - 21:14 UTC

Update

We are continuing to investigate this issue.
Posted Mar 24, 2026 - 21:02 UTC

Investigating

We are currently investigating reports of degraded application performance and delays in outbound webhooks.
Posted Mar 24, 2026 - 20:36 UTC
This incident affected: Management Portal and Report Access and Integrations.