Users unable to login

Incident Report for HappyCo

Resolved

This incident has been resolved and users are able to login again.
Posted Jul 16, 2026 - 10:00 UTC

Monitoring

The ability to login has been restored and we are continuing to monitor.
Posted Jul 16, 2026 - 09:52 UTC

Identified

We have traced the issue to one of our partners and they are working to resolve the issue.
Posted Jul 16, 2026 - 09:47 UTC

Update

We are continuing to investigate this issue.
Posted Jul 16, 2026 - 09:34 UTC

Investigating

Some users are currently unable to login to HappyCo via the Web and the Mobile App.
Posted Jul 16, 2026 - 09:33 UTC
This incident affected: Management Portal and Report Access.