Degraded Application Performance

Incident Report for HappyCo

Resolved

This incident has been resolved.
Posted Jul 29, 2026 - 01:25 UTC

Monitoring

We've implemented a fix and are currently monitoring.
Posted Jul 28, 2026 - 20:57 UTC

Update

We're continuing to investigate performance.
Posted Jul 28, 2026 - 20:46 UTC

Investigating

We are currently investigating this issue.
Posted Jul 28, 2026 - 20:14 UTC
This incident affected: Management Portal and Report Access.